MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - Fresh Installation - Backup Profile problem

Nightingale Forums

Full Version: Fresh Installation - Backup Profile problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I just freshly installed Windows 7 and installed Nightingale 1.12.1. I started it one time and then replaced the nightingale profile folder with the backup I made before installing Windows 7.

Not a single music file from my collection is shown on startup with the old profile. Any hints what to look for?
Is the music in the same previous location ?
(01-20-2014, 07:06 PM)GeekShadow Wrote: [ -> ]Is the music in the same previous location ?

Sure! The folder is the same and is being set under Watch Folder Settings for being automatically watched for changes.

If I change a filename of one mp3-file this file is being added to the library. But all other files do not appear without touching them.

Edit:The music folder is the same location as before new installation (simply f:\musik), but I formatted the drive and created a new partition. Maybe this drive/partition/folder now has a new unique id which is different to the former. Any hints where in the profile such a GUID can be found?

OS is Windows 7 64 Bit
Did you replace the contents of your new defualt profile folder with the one of the old (so the contents of %appdata%/Nightingale/[randomstuff].default]) or did you replace the contents of the whole Nightingale folder?
(01-20-2014, 10:47 PM)freaktechnik Wrote: [ -> ]Did you replace the contents of your new defualt profile folder with the one of the old (so the contents of %appdata%/Nightingale/[randomstuff].default]) or did you replace the contents of the whole Nightingale folder?

I always backup the whole profile c:\Users\johndoe\AppData\Roaming\Nightingale\ exactlay as I do it with Firefox or Thunderbird.

I just found the problem. I had migrated from Songbird (from version 1.10.2) to Nightingale a few months ago. All worked well until now. The problem is that the migration did not changed the db-entries in prefs.js

user_pref("songbird.library.loader.0.databaseLocation", "C:\\Users\\johndoe\\AppData\\Roaming\\Songbird2\\Profiles\\johndoe\\db\\main@library.songbirdnest.com.db");

So the old Songbird database was used until now. After the fresh installation of Windows 7 the old Songbird profile with its database are gone and now this error appears.
Just tested the migration with an old Songbird profile as described under http://wiki.getnightingale.com/doku.php?...m_songbird and the migration failed. In prefs.js still the db-files from the Songbird-profile folder are used.

user_pref("songbird.library.loader.0.databaseLocation", "C:\\Users\\johndoe\\AppData\\Roaming\\Songbird2\\Profiles\\k6vhg5la.default\\db\\main@library.songbirdnest.com.db");

Songbird-profile version before migration: LastVersion=1.10.2_20120119032051/20101201201839
Nightingale-profile version after migration: LastVersion=1.12.1_20140111214227/20101201201839

Was this migration code tested anytime?
There is no real migration code, as our structure is identical to Songbird's, so you just use a Songbirdprofile in Nightingale. I never heard of that pref, and I think no one of us was aware, that it even existed. It makes very little sense to have such a prefrence by default, but I checked in my profile, and it seems like that's the case.
(01-21-2014, 02:08 AM)freaktechnik Wrote: [ -> ]There is no real migration code, as our structure is identical to Songbird's, so you just use a Songbirdprofile in Nightingale. I never heard of that pref, and I think no one of us was aware, that it even existed. It makes very little sense to have such a prefrence by default, but I checked in my profile, and it seems like that's the case.

I now tried a migration with editing the prefs.js file and replacing in the prefs songbird.library.loader.0.databaseLocation,
songbird.library.loader.1.databaseLocation
songbird.library.loader.2.databaseLocation
the path to songbird2 into nightingale.

Seems to work this way.

I think this should be inserted into the Wiki migration article:

http://wiki.getnightingale.com/doku.php?...m_songbird

If you don't do this, your database is stored in the songbird2 profile and all other things in the nigthingale profile. If you delete the songbird2 profile you will lose your library information as it was in my case.

Luckily, I haven't deleted the songbird2 folder and I hope I can get that data back into my Nightingale profile.
Phew, I was afraid that you had already delted the songbird2 folder. It should be pretty straight forward then, I'd hope!

I added a step 3 to the wiki article. I'm not really good at writing "consumer friendly" instructions, but it should do for now (and hopefully people will improve it).
(01-21-2014, 04:14 AM)freaktechnik Wrote: [ -> ]Phew, I was afraid that you had already delted the songbird2 folder. It should be pretty straight forward then, I'd hope!

I added a step 3 to the wiki article. I'm not really good at writing "consumer friendly" instructions, but it should do for now (and hopefully people will improve it).

No, I just replaced the Windows installation HD with a new one. The old one is still there. Had not the time to repartition it. Thought at first it was a problem with GUID for HDs, partitions or something.

Btw, good work to change the wiki that fast.