MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - Nightingale and ALSA

Nightingale Forums

Full Version: Nightingale and ALSA
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was wondering if Nightingale will be willing to use ALSA? I hope so!!! I've disabled PulseAudio in Ubuntu 10.10 in order to get Skype 2.1.0.81 to use my Logitech ClearChat USB Headset, and have found that I have to use Songbird 1.4.3 (unless I'm doing something wrong) because Songbird 1.8.0 refuses to use ALSA to play mp3's.
Doesn't Songbird and Nightingale run on gstreamer? So to make them work with ALSA you'd need to install the gstreamer0.10-alsa package.
(02-06-2011, 03:43 AM)Ezekiel000 Wrote: [ -> ]Doesn't Songbird and Nightingale run on gstreamer? So to make them work with ALSA you'd need to install the gstreamer0.10-alsa package.

I actually have that installed, and STILL couldn't get Songbird 1.8.0 to play mp3's using ALSA!!! Any idea what I was doing wrong?
Sorry I can't help more than that as I haven't disabled PulseAudio. The only thing I'd say is open Songbird from the terminal and see if any messages come up when you try to play a song, also check the error console in Songbird. (Tools -> Error Console)
(02-06-2011, 06:18 AM)Ezekiel000 Wrote: [ -> ]Sorry I can't help more than that as I haven't disabled PulseAudio. The only thing I'd say is open Songbird from the terminal and see if any messages come up when you try to play a song, also check the error console in Songbird. (Tools -> Error Console)

That's OK, as I'm not having a problem with Songbird 1.4.3, and to me it looks and behaves exactly like Songbird 1.8.0. My actual question was whether Nightingale will work with ALSA, or only with PulseAudio.

Enabling gstreamer-alsa won't help for vanilla Songbird as they are built using their own drivers, so if it doesn't work without PulseAudio installed then they probably use it internally. Nightingale won't have this issue as we are working towards only using system drivers.
(02-07-2011, 01:42 PM)pythonian4000 Wrote: [ -> ]Enabling gstreamer-alsa won't help for vanilla Songbird as they are built using their own drivers, so if it doesn't work without PulseAudio installed then they probably use it internally. Nightingale won't have this issue as we are working towards only using system drivers.

That sounds great! I can't wait for Nightingale to be released.