MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - disable autoadd & messed up system-volume

Nightingale Forums

Full Version: disable autoadd & messed up system-volume
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello community.
Im have been using nightingale for a while now and it become my mediaplayer of choice Smile
But there are a few things Id like to change and hope, that you could help me.

I am using Nightingale 1.11.1 running on debian wheezy with gnome-shell 3.4.2.
I am not sure which information else could be helpful, so if I forgot something, please ask Smile


When I play a file in nightingale, its automatically added to my Media-library.
My problem is, that I often listen to files only once and I always have to delete them from my library afterwards.
Is there any way to disable the "auto-add" function, so that nothing is added until I explicitly tell it so?
I couldnt find a suiting option in the about:config


Also nightingales volume messes with my system-volume.
When I change my overall system-volume, its reset back the moment Nightingale starts a different track or I change the volume inside Nightingale.
I am not sure, how the value of the volume its set back to, is defined. Its not the maximum-value and also not the value that was set when I logged out/in (maybe the value, when my computer was shut down?)

I hope, someone can help me Smile
(04-09-2013, 12:42 AM)Jodli Wrote: [ -> ]When I play a file in nightingale, its automatically added to my Media-library.
My problem is, that I often listen to files only once and I always have to delete them from my library afterwards.
Is there any way to disable the "auto-add" function, so that nothing is added until I explicitly tell it so?

Nightingale is based on the idea of a media library, managing it is one of its core features. That's why Nightingale and similar programs do not support the direct playback of files. However, Nightingale has two major advantages over most other audio players: 1. it is highly customizeable, so if you need additional features you may write an add-on adding the functionality and 2. it is able to bind to any browseable media source. While 1. will not help you if you're not a developer, the second point has some interesting effects:

Maybe you noticed that Nightingale is able to parse media urls when browsing. When you visit a website supporting that kind of integration, a playlist is displayed on the bottom of the page - which is not added to your local library. You can use this playlist just like any other playlist in your library, e.g. play it, choose a playback order etc.
This feature also allows to bind to folders: if you hold tracks you want to play in a specific folder, you can just open a new tab and enter the folder's path into the address bar - Nightingale will extract media files from the list of files and deliver it to you as a playlist - without adding it to the library.

There might also be some add-ons available to integrate folders into the service pane, but I'm not sure about that right now. If not, you could fill an add-on suggestion if you need something different.
What rsj didn't mention: you can actually disable this "autoadd". There is a preference in the settings window, which folder to watch. I think on the top left is a checkbox to disable folder watching. Unfortunately I'm not near a computer for the next few days and thus can't give you exact instructions. But I'm sure someone else could.
(04-10-2013, 08:15 AM)freaktechnik Wrote: [ -> ]What rsj didn't mention: you can actually disable this "autoadd". There is a preference in the settings window, which folder to watch. I think on the top left is a checkbox to disable folder watching. Unfortunately I'm not near a computer for the next few days and thus can't give you exact instructions. But I'm sure someone else could.

From what I understand he doesn't want tracks to be added on playback, while disabling watch folders only disables importing of new files (and deletion of deleted ones if I remember correctly) within a folder. This preference - at least on windows with the RC for 1.12 - does not affect the behaviour when playing songs from outside the library.
Thanks for support Smile

Yes. I want to be able to play files without that nightingale will "remember" the file - no matter where this file is located.

Thanks for your suggestion, opening the folder with the browser. Thats a good idea Smile

As it I encountered, my main problem seem to be, that I am using partyRuffle, which - as far as I can tell - adds every file that its played by this add on.
When I have time, I will look into the source. Maybe I can change that behaviour for me.


Have you any idea, why nightinalge affects my system sound volume or what I could do about it?
(04-13-2013, 02:16 AM)Jodli Wrote: [ -> ]As it I encountered, my main problem seem to be, that I am using partyRuffle, which - as far as I can tell - adds every file that its played by this add on.
When I have time, I will look into the source. Maybe I can change that behaviour for me.
Feel free to ask here or in IRC if you need help on that Smile

(04-13-2013, 02:16 AM)Jodli Wrote: [ -> ]Have you any idea, why nightinalge affects my system sound volume or what I could do about it?

Maybe some of our linux guys can help you on that, but I don't have a clue.
(04-13-2013, 05:19 AM)rsjtdrjgfuzkfg Wrote: [ -> ]
(04-13-2013, 02:16 AM)Jodli Wrote: [ -> ]Have you any idea, why nightinalge affects my system sound volume or what I could do about it?

Maybe some of our linux guys can help you on that, but I don't have a clue.

As far as I know, Nightingale tries to dominate over the system volume and sets it to its own volume. However it doesn't correctly adapt to every system volume change on linux systems. I remember there being issues on some distros earlier. So yes, our volume behaviour on linux is quite imperfect and dick-ish. We also capture the volume change keys and don't change the system volume with it.
I usually leave it at 100% and just control it with alsa.
I am sorry for my late reply. I am swamped with work at the moment, so I couldnt find time/ motivation Smile
Thank you all for your replies!

As far as I can see, the partyRuffle-Addon creates a media-list which is bound to the library.
Maybe Ill find a way around that, as soon as I get time - unfortunately the documentation from songbird (http://developers.songbirdnest.com/) seems to be down.


Maybe my sound-issue is already solved in the 1.12-version (The changelog reads, like there have been some changes in that direction). Unfortunately it requires taglib 1.8 which isnt in the current debian-repositorys (only 1.72). So Ill have to wait on that^^

@ilikenwf
What do you mean "control with alsa"? You mean the alsa-server directly? Over a terminal, or how is that manageable?
We have a special version with bundled taglib. Listed as Unity/GNOME Version: http://getnightingale.com/all-versions.php. the sound issue probably isn't fixed, as it only fixed a restoring issue on startup, where the slider wouldn't fill up on startup (the endpoint already being at the correct position from the beginnig) until he was move a bit. This is not related to the actual volume, the sound plays.
Pages: 1 2