MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - Media won't import at all!

Nightingale Forums

Full Version: Media won't import at all!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I am running Linux Mint Debian edition and just found out about nightingale. I have been using Songbird. I have installed the build from the main download page, and tried compiling myself from GIT. The application loads up fine, but I am unable to import any of my music. It acts like it is going to import and then just stops like it completed and the library is still empty! Music imported to Songbird just fine. I have my music in /home/myname/Music, which is the default. I wanted to switch to nightingale since it's completely open-source, but it's useless if I can't import any media. Suggestions?

Thanks.

-hogfan
(07-29-2012, 12:14 PM)hogfan Wrote: [ -> ]The application loads up fine, but I am unable to import any of my music. It acts like it is going to import and then just stops like it completed and the library is still empty!

Welcome to the Nightingale community Smile

I'm not on Linux, but on Windows both Songbird and Nightingale need some time to display the entries after the first import. You can see that by the vertical scroll bar appearing, while the information about the entries is filled some time later. Maybe the import was completed properly?

If not, maybe there are hints in the error console? Open Tools|Error console and post the messages you get, if any.
(07-29-2012, 12:14 PM)hogfan Wrote: [ -> ]I am running Linux Mint Debian edition and just found out about nightingale. I have been using Songbird. I have installed the build from the main download page, and tried compiling myself from GIT. The application loads up fine, but I am unable to import any of my music. It acts like it is going to import and then just stops like it completed and the library is still empty! Music imported to Songbird just fine. I have my music in /home/myname/Music, which is the default. I wanted to switch to nightingale since it's completely open-source, but it's useless if I can't import any media. Suggestions?

Thanks.

-hogfan

I've been a Linux Mint user for a long time, I'm currently using Maya, but I used to use LMDE and I had some problems with Nightingale, but not this particular problem. First off, it would help if you could tell me: are you on UP4, are you using MATE or Cinnamon, and are you on i386 or amd64? If you can give me some details, I'll try to track down the problem.
Sure, I was actually having some other problems, so I did a fresh install of Maya last night. Just download the nightingale from the main page and have it in my home directory. I'm having the same issue on Maya. Loads fine, won't import media into the library. I am on Linux Mint 13 Maya x64. thanks.

-hogfan

BTW. Running Cinnamon Edition here.
(07-30-2012, 02:13 PM)hogfan Wrote: [ -> ]Sure, I was actually having some other problems, so I did a fresh install of Maya last night. Just download the nightingale from the main page and have it in my home directory. I'm having the same issue on Maya. Loads fine, won't import media into the library. I am on Linux Mint 13 Maya x64. thanks.

-hogfan

BTW. Running Cinnamon Edition here.

I think you're having the same issues I had, Cinnamon causes Nightingale's media import window to crash. Try this: Delete the folder
Code:
~/.nightingale
Startup Nightingale, once Nightingale has finished loading, restart Cinnamon with
Code:
ALT + F2
Go to Edit->Preferences->Media Importer->Watch Folders, make sure "Automatically watch for changes in following folder is checked", then click the "browse" button and locate your music folder and press open. Close the "Preferences" window and you should see a dialogue that says something like "Do you want to scan your media folder for changes?" click "Yes" and it should import your music.
(07-31-2012, 02:38 AM)Timmythepirate Wrote: [ -> ]
(07-30-2012, 02:13 PM)hogfan Wrote: [ -> ]Sure, I was actually having some other problems, so I did a fresh install of Maya last night. Just download the nightingale from the main page and have it in my home directory. I'm having the same issue on Maya. Loads fine, won't import media into the library. I am on Linux Mint 13 Maya x64. thanks.

-hogfan

BTW. Running Cinnamon Edition here.

I think you're having the same issues I had, Cinnamon causes Nightingale's media import window to crash. Try this: Delete the folder
Code:
~/.nightingale
Startup Nightingale, once Nightingale has finished loading, restart Cinnamon with
Code:
ALT + F2
Go to Edit->Preferences->Media Importer->Watch Folders, make sure "Automatically watch for changes in following folder is checked", then click the "browse" button and locate your music folder and press open. Close the "Preferences" window and you should see a dialogue that says something like "Do you want to scan your media folder for changes?" click "Yes" and it should import your music.

Ok, I tried following those instructions, but even after restarting cinnamon the media import window is still crashing. Any other info I can provide to help ts the issue?

EDIT: Ok, another update. To eliminate Cinnamon from the mix, I logged out and logged into Gnome Classic. Import still fails in Gnome Classic as well, so it appears the issue is not specific to the Cinnamon Desktop Environment.

-hogfan
I've gotten both Maya and LMDE to run Nightingale but, I don't remember how, I solved the problem on LMDE. I just installed a fresh copy of LMDE 201204, so I'll install Nightingale and see how to get it to work.
I've got a guess of what the problem might be, try this build that I compiled and see if it works.http://sourceforge.net/projects/ngale-bi...z/download This build is based on Songbird 1.12, so it may have some issues, but it will at least help me tell if the problem is what I think it is. It might help to delete
Code:
~/.nightingale
first.
Ok, I tried that last night. Deleted the .nightingale folder out of my home directory as well. When it tried to import the media the import window didn't crash as soon as before, but after the first attempted import the Library window showed and XML parse error. I re-launche the app and the library window look ok, but no songs. Then I tried doing the Watch Folders trick you mentioned, but no dice. Please let me know if I can provide addtional information to ts. Thanks.

-hogfan
(08-03-2012, 01:41 AM)hogfan Wrote: [ -> ]Ok, I tried that last night. Deleted the .nightingale folder out of my home directory as well. When it tried to import the media the import window didn't crash as soon as before, but after the first attempted import the Library window showed and XML parse error. I re-launche the app and the library window look ok, but no songs. Then I tried doing the Watch Folders trick you mentioned, but no dice. Please let me know if I can provide addtional information to ts. Thanks.

-hogfan

That's strange. I'm using this Nightingale build on UP5, and it works fine. I'm not quite sure what else could be happening to cause an error. Maybe, one of the devs might have an idea.
Pages: 1 2