MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - Enable other video format import

Nightingale Forums

Full Version: Enable other video format import
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Is it possible to allow importing other video since not it uses native gstreamer ? earlier beta it used to work.

I guess so. But I'm not sure how the whole restriction thing works...
You might try to rename your files to a "supported" format as a workaround until we found the big red switch Tongue
By default Songbird, and thus Nightingale, only allows video importing of ogv files. To allow Nightingale to import more video formats type this into the address bar:
Code:
about:config
This will show you the Nightingale preferences. Right click and make a new string. Name it
Code:
songbird.mediacore.gstreamer.videoExtensions
and set it's value as something like
Code:
mov, mp4, avi, divx, flv, mkv
Nightingale will now be able to play videos with the mov, flv, avi, extension or whatever other extension you have entered.

To let Nightingale play these formats by default, you'd have to add "songbird.mediacore.gstreamer.videoExtensions" to the preferences list in the Nightingale source code.
@Timmy: mind changing the default prefs or whatever and putting in a pull request for this? It SHOULD definitely be enabled!
(03-15-2012, 01:27 PM)ilikenwf Wrote: [ -> ]@Timmy: mind changing the default prefs or whatever and putting in a pull request for this? It SHOULD definitely be enabled!

I'll see what I can do.

Sweet! I'd do it, but I'm going to bed very soon.
(03-15-2012, 02:00 PM)ilikenwf Wrote: [ -> ]Sweet! I'd do it, but I'm going to bed very soon.

I made the change and made a pull request. I didn't know what formats to add, so I just added the most common ones.

That's cool. I'll merge it in, thanks dude.
Still not working for me on linux...Smile (Didn't check thread for so long !) Added above said param in about:config
(04-08-2012, 05:36 AM)jigarshah Wrote: [ -> ]Still not working for me on linux...Smile (Didn't check thread for so long !) Added above said param in about:config

The first thing is to make sure you have all the necessary gstreamer packages installed. Second, can you tell me what distro you are using and what the specific problem is: Are the videos not importing? Not playing?

EDIT: Also, what type of video file are you trying to play?
Pages: 1 2