MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - How to build Nightingale

Nightingale Forums

Full Version: How to build Nightingale
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
(12-06-2011, 08:26 PM)stanz Wrote: [ -> ]
(12-05-2011, 05:32 AM)Kompulsa Wrote: [ -> ]Hi. Where do I find the executable that I use to run Nightingale after install.
This is what I got when I tried to run it:
@ubuntu:~/Desktop/ng/compiled-release-x86_64/dist$ ./nightingale
(nightingale-bin:20144): Gdk-WARNING **: gdk_window_set_icon_list: icons too large
@ubuntu:~/Desktop/ng/compiled-release-x86_64/dist$

Won't work in terminal...
Might as well create a "custom launcher" for the panel (or where ever).
In the "/dist" folder--use the "nightingale" shell script (not the nightingale-bin) for command.
Code:
/Nightingale-1.8_2011.10/compiled-release-x86_64/dist/nightingale
First run took a few seconds to load.
Also in the "/app/branding" folder, set the icon you need (the xpm worked for me).
Cool

It didn't work in GNOME either. Could you elaborate?

Double clicking the sh and clicking run didn't work either.
Problem solved. Nightingale ran and played a FLAC when I ran it using sudo, and Matt pointed out that it was because I ran build.sh as root in the first place, so I rebuilt it without sudo and now it works without sudo. Smile
Quote:I have nightingale in /usr/share/nightingale and adobe flash in /usr/lib/adobe-flashplugin/libflashplayer.so

I just ran the following command:
Code:
sudo ln -s /usr/lib.adobe-flashplugin/libflashplayer.so /usr/share/nightingale/plugins/libflashplayer.so

And now I can play flash just fine.


Please can I ask the question, can anyone tell me how to change the command so that I can adapt it to Fedora?

I have an otherwise perfectly working install of Nightingale (apart from the Last.fm add-on which scrobbles but cann't stream radio).

Thanks

Ash

(12-09-2011, 06:36 AM)nighthawk Wrote: [ -> ]
Quote:I have nightingale in /usr/share/nightingale and adobe flash in /usr/lib/adobe-flashplugin/libflashplayer.so

I just ran the following command:
Code:
sudo ln -s /usr/lib.adobe-flashplugin/libflashplayer.so /usr/share/nightingale/plugins/libflashplayer.so

And now I can play flash just fine.


Please can I ask the question, can anyone tell me how to change the command so that I can adapt it to Fedora?

I have an otherwise perfectly working install of Nightingale (apart from the Last.fm add-on which scrobbles but cann't stream radio).

Thanks

Ash

If you've installed flash from adobe's website, I think it should put the flash plugin in the /usr/share/lib/adobe-flashplugin directory. So, the command should work. If it's not in that directory, search for
Code:
libflashplayer.so
in your file browser. Then replace
Code:
/usr/share/lib/adobe-flashplugin
with whatever directory the plugin is in on your system.
Hi all,

I'm not able to build Nightingale 1.8 on Ubuntu 11.10! I pulled it down with:

Code:
git clone git://github.com/nightingale-media-player/nightingale-hacking.git nightingale

It look like it doesn't download the dependecies!(Look at the red colored line)
In the Readme file it says:
Quote:If on Linux, simply run the build.sh script. It will download the deps and build the app for you. You'll generally need the usual build deps
for most software packages, though.
Huh

Code:
make -C /home/malte/Programmieren/Projekte/nightingale/compiled
make[1]: Betrete Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled'
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/chrome
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/components
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/defaults
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/extensions
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/gst-plugins
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/jsmodules
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/lib
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/plugins
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/defaults/preferences
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/defaults/profile
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/scripts
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/searchplugins
install -c -d -m 755 /home/malte/Programmieren/Projekte/nightingale/compiled/dist/xulrunner
set -e;  \
    make tier_base;  make tier_deps;  make tier_appbase;  make tier_componentsbase;  make tier_ui;  make tier_componentsall;  make tier_extensions;  make tier_branding;  true
make[2]: Betrete Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled'
BUILDING base TIER; directories: build tools/lib tools
make -e export_tier_base
make[3]: Betrete Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled'
set -e;  \
    make -C build export;  make -C tools/lib export;  make -C tools export;  true
[b][color=#FF0000]/bin/sh: cannot open /home/malte/Programmieren/Projekte/nightingale/dependencies/linux-x86_64/mozilla-6.0.2/include/mozilla-config.h: No such file[/color][/b]
make[4]: Betrete Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled/build'
rm -f -f sbBuildInfo.mk
/usr/bin/python /home/malte/Programmieren/Projekte/nightingale/build/make-buildinfo.py -i /home/malte/Programmieren/Projekte/nightingale/build/sbBuildInfo.mk.in -o sbBuildInfo.mk \
    -k SB_MOZILLA_VERSION=
make[4]: Verlasse Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled/build'
make[4]: Betrete Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled/tools/lib'
/home/malte/Programmieren/Projekte/nightingale/build/config.mk:62: *** Could not derive SB_MOZILLA_VERSION.  Schluss.
make[4]: Verlasse Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled/tools/lib'
make[3]: *** [export_tier_base] Fehler 2
make[3]: Verlasse Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled'
make[2]: *** [tier_base] Fehler 2
make[2]: Verlasse Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled'
make[1]: *** [default] Fehler 2
make[1]: Verlasse Verzeichnis '/home/malte/Programmieren/Projekte/nightingale/compiled'
make: *** [build] Fehler 2

I think this is the same problem as rafaelcneves
First, you don't have the dependencies...build.sh grabs them if you have the proper branch checked out...

In your nightingale (or nightingale-hacking) directory, do the following:

Code:
git checkout nightingale-1.8
sh build.sh

The master branch isn't ready yet.
The array in line 18 in bulid.sh script isn't working!!!
You have to add
Code:
#!/bin/bash
at first line and change
Code:
sh build.sh
to
Code:
./build.sh
or better
Code:
./build
if you change the filename!

On Ubuntu 11.10 it is working as bash for me but not as sh!!!
(12-09-2011, 08:06 AM)Timmythepirate Wrote: [ -> ]
(12-09-2011, 06:36 AM)nighthawk Wrote: [ -> ]
Quote:I have nightingale in /usr/share/nightingale and adobe flash in /usr/lib/adobe-flashplugin/libflashplayer.so

I just ran the following command:
Code:
sudo ln -s /usr/lib.adobe-flashplugin/libflashplayer.so /usr/share/nightingale/plugins/libflashplayer.so

And now I can play flash just fine.


Please can I ask the question, can anyone tell me how to change the command so that I can adapt it to Fedora?

I have an otherwise perfectly working install of Nightingale (apart from the Last.fm add-on which scrobbles but cann't stream radio).

Thanks

Ash

If you've installed flash from adobe's website, I think it should put the flash plugin in the /usr/share/lib/adobe-flashplugin directory. So, the command should work. If it's not in that directory, search for
Code:
libflashplayer.so
in your file browser. Then replace
Code:
/usr/share/lib/adobe-flashplugin
with whatever directory the plugin is in on your system.


I spent sometime on this but had to deal with the plugins manually because I got an error report that the file or directory didn't exist. Anyway, that worked but I am still unable to play Last.fm radio, jamendo, etc through the browser which I presume is one of two things API connection or a missing connection that is to do with the plugins.
I "fixed" build.sh on both branches to have the comment up top - sorry I forgot that part. As for renaming, that's not possible because there's a directory named build and it would conflict...furthermore, using the .sh extension is standard. We can't cater to Ubuntu or any other distro specifically in the mainline repo.

In a PPA, PKGBUILD, or whatever else, sure, but not here.
Hey guys,

I don't know if this is the right place to post, but here is more or less a list of packages to build ng on opensuse 13.2


Code:
# zypper install git autoconf  gcc-c++ gtk2-devel dbus-1-glib-devel libtag-devel gstreamer-plugins-base-devel gstreamer-0_10-plugins-base-devel libidl-devel zip unzip
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15