MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - Corrupted profile - Metadata bug

Nightingale Forums

Full Version: Corrupted profile - Metadata bug
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there,

I haven't seen any topic about the problem I'm encountering for a week now, so I registered and here I am Big Grin

Here is my situation : when I try to import new songs in Nightingale, metadata is displaying properly, I can edit it and all. But when I quit, and at the next running of Nightingale, the new songs I just imported display data like "57e4ab12-0b16-48e8-9c90-fae0a59c5490" instead of Artist, Album etc. and I can't edit it anymore. Importing new songs also creates some bugs in playlists which do not update properly anymore. Finally, when I delete these new songs from the library, everything works fine again... I tried importing different songs, several times, and it's always the same problem.

I suppose the issue comes from my local profile (which I use on two different windows sessions, and originally imported from Songbird (I'm running Windows 7 x64)) that could be corrupted. I had some PC crash recently, while Nightingale was probably running, it may be linked.

I could start a new profile and re-import all songs but this way I'm losing loads of data (ratings, playing counts...)... Is there anyway to fix it, by, I don't know, editing some files in the profile ? Or maybe could I copy the metada stuff I don't want to lose from the profile and put it in a brand new one ?

Thanks.
I have no idea what's going on with your profile, sounds sinister though...

I recommend trying to start over, but don't delete your current profile, still back it up, in case something goes wrong while migrating or similar.
There are extensions to export extra data, for example ratings: http://wiki.getnightingale.com/doku.php?...ratingfile
I couldn't find the one to export other data too, but I think it exists.
(04-27-2014, 07:26 AM)freaktechnik Wrote: [ -> ]I couldn't find the one to export other data too, but I think it exists.
For static playlists: Playlist Export

For settings (RatingFile required): BackupBird
Next time it happens, try and note the steps to reproduce if possible, as well as your OS information and Nightingale version.
Hi again,

First of all thanks for answering. It's been a week and I tried several things to fix my problem, without success, here are some updates :

I first found a corrupt section in the library, something like 10 songs that don't display any metadata in the list ; I can still play them, and they show the correct data in the playing data field, but still not in the library. when I scroll over them I have a message that says "Nightingale has detected that your Library is corrupt and cannot be read. In order for Nightingale to function correctly, your library needs to be deleted[...]"
Then I have two buttons, either I carry on with the library anyway, or I reset it. Trying to reset it just restarts the player, but nothing changes. I can't delete these songs or anything (they are not in read only mode, can modify them but not through Nightingale).

I tried using the add-ons you advised me, but on both of them, when I try to export data, I'm stuck around 70%, with an error message that a script is not responding. If I carry on with the script, and try to re-import the data, it says that the .xml file is corrupted or something.
When I open the .xml file to see what's wrong with it, I find that some of the data is randomly replaced by that "57e4ab12-0b16-48e8-9c90-fae0a59c5490" stuff, while this data is diplayed properly in the library. Quite puzzling me.

I finally gave up, as I found a former version of my profile dated from february, in which I put the songs I have added since then. In the end I've lost some months of metadata, it's no big deal. I've backed my corrupt profile up, and I'll regularly save my profile from now on.

Some questions are left unanswered about the causes of this mess though. Could it be linked to the fact I've been using the same profile on two windows sessions ? The strange thing is that whereas the profiles have different paths ([username]/appdata/...), changing data through Nightingale will also change the other one. Well I have no idea how a profile do work...

Here we are, I tried to make it clear as newbie as I am, so it's a bit long, but I guess that's the end of the story.
(05-03-2014, 02:24 AM)Pastakrewel Wrote: [ -> ]I tried using the add-ons you advised me, but on both of them, when I try to export data, I'm stuck around 70%, with an error message that a script is not responding. If I carry on with the script, and try to re-import the data, it says that the .xml file is corrupted or something.
When I open the .xml file to see what's wrong with it, I find that some of the data is randomly replaced by that "57e4ab12-0b16-48e8-9c90-fae0a59c5490" stuff, while this data is diplayed properly in the library. Quite puzzling me.

Can you extract the crucial bits and send them to me (pastebin, post in code tags, send me a mail with the file, etc)? Maybe I can figure out what's wrong there, as "that stuff" seems like a media id for me...

Good you found a solution, though.