Nightingale Forums

Full Version: Nightingale on Lubuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello

I've just installed nightingale on my lubuntu, it's great, but it keeps on crashing all the time. I can play a bit of music but basically as soon as I click on a button, nightingale just stops.

Any idea of how to fix that ?

Thanks !!!
How did you install nightingale? From the ppa or are you running a prebuilt build, did you build it on your own?
I downloaded the bz archive from the website, extracted it in my files and run the launcher. Is there a better way to do it ?
thanks
You are using Lubunut, which is a Ubuntu based distribution, which is based on Debian, which has a broken taglib. Soo, I'm not sure if apt(itude) is available but if it is, try using the version from the ppa. The version from the ppa should work without problems on debian based distros. Especially since an installation from the ppa fetches all the depencies you need for nightingale to run correctly (gstreamer).
So I've installed nightingale using the ppa, nightingale shows up in the menu. However, it does not manage to launch itself. The task manager shows that something is launched but then doesn't give anything and stops. I once had had an error message but not anymore so I can't even copy it...
You're probably missing libs. Run from bash and paste the output..
I've run the following commands. If I understand well, it has something to do with the fact that Lubuntu uses lxde instead of unity. Or am I totally wrong ?


lydie@little-ludicia:/usr/share/nightingale$ nightingale

(process:3715): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
ERROR! Could not call boundObserver.observe(). Key = metadata.title
[Exception... "'[JavaScript Error: "mlyrics.pane.gMM.playbackControl is null" {file: "chrome://mlyrics/content/jscripts/paneWindow.js" line: 676}]' when calling method: [sbIRemoteObserver::observe]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: file:///usr/share/nightingale/components/sbDataRemote.js :: anonymous :: line 369" data: yes]
** Message: Unity Integration: loading

(nightingale-bin:3715): GLib-GIO-ERROR **: Settings schema 'com.canonical.indicator.sound' is not installed

Trace/breakpoint trap (core dumped)


lydie@little-ludicia:/usr/share/nightingale$ ./nightingale-bin

(process:3887): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
ERROR! Could not call boundObserver.observe(). Key = metadata.title
[Exception... "'[JavaScript Error: "mlyrics.pane.gMM.playbackControl is null" {file: "chrome://mlyrics/content/jscripts/paneWindow.js" line: 676}]' when calling method: [sbIRemoteObserver::observe]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: file:///usr/share/nightingale/components/sbDataRemote.js :: anonymous :: line 369" data: yes]
** Message: Unity Integration: loading

(nightingale-bin:3887): GLib-GIO-ERROR **: Settings schema 'com.canonical.indicator.sound' is not installed

Trappe pour point d'arrĂȘt et de trace (core dumped)
that's vpossible, since the ppa version is built for unity enviroments. You can try deleting the unity extension from nightingale. It's in nightingale's installation folder under extensions.
That worked ! thank you guys. nightingale really rocks, that's exactly what I had been looking for a while. Smile