MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
MyBB Internal: One or more warnings occurred. Please contact your administrator for assistance.
Nightingale Forums - Readme file

Nightingale Forums

Full Version: Readme file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm pleased about todays release and downloaded on to my ubuntu machine (had trouble on that 'corrupt files') so tried my Fedora desktop which had a working nightingale. Downloaded, unpacked and noticed this time that there is no README. file to help with installing.

I cann't get it to work Sad , Mostly because I am not very experienced with installing from source and also my normal ploy of clicking on nightingale in the file browser produces nothing.

Any help or suggests appreciated, Thanks
What method did you use to download? Git? Or by one of the archives?

Either way, you shouldn't be getting a corruption error - that was most likely your browser failing you...did you try redownloading?

As for installing, just extract the archive somewhere and run the nightingale binary inside of the nightingale directory...

We plan on having debs available in the very immediate future...
What I did is the following:

I created the folders:

~/.local/opt
~/.local/opt/bin
~/.local/share/applications
~/.local/share/pixmaps

Then I added ~/.local/opt/bin to my PATH variable:
Code:
PATH="${PATH}:${HOME}/.local/opt/bin"
(put this in your .bashrc or .zshrc or whatever)

Next I unpacked the tarball to ~/.local/opt/nightingale and placed the following script file in ~/.local/opt/bin:
Code:
#!/bin/sh
${HOME}/.local/opt/nightingale/nightingale
and made it executable:
Code:
chmod +x ~/.local/opt/bin/nightingale

That's basically it. To be able to run it from your application menu, the only thing left to do is to create a file called nightingale.desktop in ~/.local/share/applications with the following contents (do NOT make it executable):
Code:
[Desktop Entry]
Name=Nightingale
Exec=$HOME/.local/opt/nightingale/nightingale
Icon=nightingale
Type=Application
Categories=Audio;Music;Player;AudioVideo;
StartupNotify=true
and then place a version of the Nightingale icon in ~/.local/share/pixmaps/nightingale.png (about 128 or 256px is best).

Now you should be able to run Nightingale like any other application on your system from the command line and from the applications menu as well.

I use this local folder structure for all applications which I do not install from the repository.
Thanks guys,

I downloaded from the home page of the website for both Fedora and Ubuntu.

Tonight I redownloaded from the download page (after clicking the 'other systems link') and unpacked on the Fedora machine, clicked on 'nightingale' directory. Hey presto, my favorite music player is back. Despite deleting the old original version all my settings are still there but the version number is correct.

Not to worried about the laptop at the moment as that is mostly for Uni stuff but will retry this weekend.
I fixed the laptop this morning using one of the Deb's from one of the other posts. Works really well and will now test it to find any bugs, etc.