Nightingale Forums

Full Version: How to build Nightingale
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
NOTE: this tutorial will be improved, eventually. ~~ilikenwf

First, pull down the sb-trunk-oldxul branch from my git tree if you're comfortable with git and want to use about a gig of space, or just get the tarball: https://github.com/nightingale-media-pla...unk-oldxul

Then, run build.sh.

Code:
./build.sh

But I'd like to have other people try this one, so that I can make sure it builds well on everyone's distro/architecture.

Notes:
*To build, you need to have all of the gstreamer0.10 packages for your distro, svn, wget, and git (if pulling the tree down) installed, as well as the usual dependencies for building software upon your distro.

*If it gets python errors, make sure you have python2 installed, and try the build.sh script again.

*If it doesn't play music, you'll need to copy /usr/lib/gstreamer0.10/* into compiled-dist-linux-[your arch]/dist/gst-plugins and then rerun nightingale. It should then play music.
Perfect, I was just about to try building the iPod extension on Ubuntu and was looking for these! =)
(11-18-2010, 11:25 AM)pythonian4000 Wrote: [ -> ]Perfect, I was just about to try building the iPod extension on Ubuntu and was looking for these! =)

Feel free try try, but I am very confident it will fail miserably Sad. the iPod extension requires a large amount of work to get back into working state.
(11-19-2010, 07:34 AM)stevo Wrote: [ -> ]
(11-18-2010, 11:25 AM)pythonian4000 Wrote: [ -> ]Perfect, I was just about to try building the iPod extension on Ubuntu and was looking for these! =)

Feel free try try, but I am very confident it will fail miserably Sad. the iPod extension requires a large amount of work to get back into working state.

I realise that. But I just got an iPod Touch and after a week of it screwing over my music collection I now loathe iTunes, which is why I am making it my main summer project. I am thinking GNU/Linux development should be much easier since libgpod, libimobiledevice etc. are actually designed to run on that; I have been trying to compile the latest libgpod on Windows (minus iPhone etc. support from libimobiledevice) and have managed to wade through missing libraries and dependency errors to get up to the linking stage, where I am now stuck =(
Running archlinux, I'm unable to build - I'm pretty sure I have all of the equivalent deps...

Code:
make -C /media/disk/makepkg/nightingale-svn/src/trunk/compiled
make[1]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/chrome
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/components
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/defaults
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/extensions
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/gst-plugins
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/jsmodules
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/lib
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/plugins
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/defaults/preferences
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/defaults/profile
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/scripts
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/searchplugins
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/xulrunner
set -e;  \
    make tier_base;  make tier_deps;  make tier_appbase;  make tier_componentsbase;  make tier_ui;  make tier_componentsall;  make tier_extensions;  make tier_branding;  true
make[2]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
BUILDING base TIER; directories: build tools/lib tools
make export_tier_base
make[3]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
set -e;  \
    make -C build export;  make -C tools/lib export;  make -C tools export;  true
make[4]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled/build'
rm -f -f sbBuildInfo.mk
python /media/disk/makepkg/nightingale-svn/src/trunk/build/make-buildinfo.py -i /media/disk/makepkg/nightingale-svn/src/trunk/build/sbBuildInfo.mk.in -o sbBuildInfo.mk \
    -k SB_MOZILLA_VERSION=1.9.0.19
Traceback (most recent call last):
  File "/media/disk/makepkg/nightingale-svn/src/trunk/build/make-buildinfo.py", line 89, in <module>
    sys.exit(main(sys.argv[1:]))
  File "/media/disk/makepkg/nightingale-svn/src/trunk/build/make-buildinfo.py", line 74, in main
    if line.startswith(substKey):
TypeError: expected an object with the buffer interface
make[4]: *** [sbBuildInfo.mk] Error 1
make[4]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled/build'
make[3]: *** [export_tier_base] Error 2
make[3]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
make[2]: *** [tier_base] Error 2
make[2]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
make: *** [build] Error 2
(11-20-2010, 08:53 AM)ilikenwf Wrote: [ -> ]Running archlinux, I'm unable to build - I'm pretty sure I have all of the equivalent deps...

Code:
make -C /media/disk/makepkg/nightingale-svn/src/trunk/compiled
make[1]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/chrome
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/components
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/defaults
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/extensions
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/gst-plugins
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/jsmodules
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/lib
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/plugins
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/defaults/preferences
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/defaults/profile
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/scripts
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/searchplugins
install -c -d -m 755 /media/disk/makepkg/nightingale-svn/src/trunk/compiled/dist/xulrunner
set -e;  \
    make tier_base;  make tier_deps;  make tier_appbase;  make tier_componentsbase;  make tier_ui;  make tier_componentsall;  make tier_extensions;  make tier_branding;  true
make[2]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
BUILDING base TIER; directories: build tools/lib tools
make export_tier_base
make[3]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
set -e;  \
    make -C build export;  make -C tools/lib export;  make -C tools export;  true
make[4]: Entering directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled/build'
rm -f -f sbBuildInfo.mk
python /media/disk/makepkg/nightingale-svn/src/trunk/build/make-buildinfo.py -i /media/disk/makepkg/nightingale-svn/src/trunk/build/sbBuildInfo.mk.in -o sbBuildInfo.mk \
    -k SB_MOZILLA_VERSION=1.9.0.19
Traceback (most recent call last):
  File "/media/disk/makepkg/nightingale-svn/src/trunk/build/make-buildinfo.py", line 89, in <module>
    sys.exit(main(sys.argv[1:]))
  File "/media/disk/makepkg/nightingale-svn/src/trunk/build/make-buildinfo.py", line 74, in main
    if line.startswith(substKey):
TypeError: expected an object with the buffer interface
make[4]: *** [sbBuildInfo.mk] Error 1
make[4]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled/build'
make[3]: *** [export_tier_base] Error 2
make[3]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
make[2]: *** [tier_base] Error 2
make[2]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/media/disk/makepkg/nightingale-svn/src/trunk/compiled'
make: *** [build] Error 2

Hmm, it looks like there is something missing with your python install? If you are building with the i686 I know there were some libraries missing recently, I am working to rectify that.
Nah...it's 64 bit.
(11-29-2010, 04:48 AM)keeshanam Wrote: [ -> ]I am trying to compile on Ubuntu 10.10 (64-bit). I am following the instructions as above and have been successful in the past (10.04).

Receiving the following error.
Code:
install: missing destination file operand after `/media/TeraRaid/Developmet/nightingale/trunk/compiled/dist/gst-plugins/libgstcoreelements.so'
Try `install --help' for more information.

Any help would be greatly appreciated.

Note Songbird 1.8 installed currently.

Having Songbird 1.8 installed should not be a problem as they keep within their own directories.

That issue is for a missing library, and currently the dependencies directories on SVN are missing most of the library files, so I'm not sure how you even got it to compile before! If this is your only issue, you can get around it by telling the compiler to use the system's Gstreamer media core instead of its own files (so it won't be looking for that one any more), by creating a songbird.config file in the base directory of the code (same directory as songbird.mk) with the following line:

ac_add_options --with-media-core=gstreamer-system
This is what I've got.

Quote:make -C /home/olivia/nightgale/trunk/compiled
make[1]: Entering directory `/home/olivia/nightgale/trunk/compiled'
/home/olivia/nightgale/trunk/build/config.mk:44: *** Please check out or build vendor-binaries - see https://wiki.songbirdnest.com/Developer/...pendencies. Stop.
make[1]: Leaving directory `/home/olivia/nightgale/trunk/compiled'
make: *** [build] Error 2

I'm running Linux Mint 9 x64, I have all the dependencies and I believe the folder structure is correct.

EDIT: I copied the linux-x86_64 folder into 'dependencies', and now I get this:

Quote:make[5]: Leaving directory `/home/olivia/nightgale/trunk/compiled/dependencies/vendor/mozbrowser'
install -c -m 0755 /home/olivia/nightgale/trunk/compiled/dist/gst-plugins/libgstcoreelements.so
install: missing destination file operand after `/home/olivia/nightgale/trunk/compiled/dist/gst-plugins/libgstcoreelements.so'
Try `install --help' for more information.
make[4]: *** [/home/olivia/nightgale/trunk/compiled/dist/gst-plugins/libgstcoreelements.so] Error 1
make[4]: Leaving directory `/home/olivia/nightgale/trunk/compiled/dependencies'
make[3]: *** [libs_tier_deps] Error 2
make[3]: Leaving directory `/home/olivia/nightgale/trunk/compiled'
make[2]: *** [tier_deps] Error 2
make[2]: Leaving directory `/home/olivia/nightgale/trunk/compiled'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/olivia/nightgale/trunk/compiled'
make: *** [build] Error 2
Same here.

Gentoo x64
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15