Nightingale Forums

Full Version: Cover Art does not appear on Linux
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello:

I've been happily using Nightingale, and Songbird before it, on Windows for many years. I've just installed the latest Linux version on a box running Xubuntu 14.04 (Trusty Tahr). I copied my music collection over from Windows using a network share, and Nightingale works fine except for one problem. The cover art doesn't show up. When I open one of the mp3 files using vlc, or any of the linux media players, the cover art shows up, just as it does on Windows.

Is this a known problem, and is there a workaround? It's more of an annoyance than a real fault, but it would be nice to be able to see the album covers. Thanks in advance for any advice.
Hm. While some file formats are not yet supported for album art reading (FLAC!), it works for me with mp3 files on Debian (with my own build, not using a package).

I cannot quite recall if we use your system's taglib in some configurations, if so, an unsupported taglib version could be related to the issue. Maybe simply try building yourself, unless some more package-affine folks have an idea what could be wrong.
Thanks for the quick answer. I'll try doing a build in the next few days, and report back on the results.
I dowloaded this tarball: nightingale-media-player-nightingale-hacking-nightingale-1.12.1-0-g9b9c8bf.tar.gz and unpacked it. I read the README file, and installed the mentioned dependencies. Then I noticed this passage:
Quote:Also note that because of Ubuntu and Debian's incompatible taglib,
you'll want to use 

ac_add_options --with-taglib-source=packaged

option to your nightingale.config
Since I am working on Xubuntu, this applies to me, and it sounds like it might be related to my problem. The thing is, I can't find a file named nightingale.config. Should I create one, and put this in as the only content? What directory does it belong in? Thanks in advance for your advice.
(04-16-2016, 01:04 AM)datasmith Wrote: [ -> ]The thing is, I can't find a file named nightingale.config. Should I create one, and put this in as the only content? What directory does it belong in?

Oh, Sorry. I completely forgot about that one. The nightingale.config can be created in the root folder (the same in which build.sh resides). It is not part of the tarball or the git repository as it is designed for local changes in the buildsystem. As one usually creates the file when checking out the repository, and never needs to touch it again, I completely forgot that that step is required.

So, yes, just create the file with the content you wrote (and probably add 'ac_add_options --enable-release'), and run build.sh.
Hello again:

Sorry to be such a bother, but I don't build c++ projects very often. All I ever use these days is CoffeeScript in the browser, and python everywhere else. Anyway, when I followed your previous instructions, I found that autoconf was required but not installed. I fixed that, but on the next try, I got this error message.

Quote:checking for gtk+-2.0... Package gtk+-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found
configure: error: Library requirements (gtk+-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
make: *** [/home/mjm/CurrentData/AssortedStuff/NightingaleSource/nightingale-media-player-nightingale-hacking-9b9c8bf/compiled/config.status] Error 1
I searched for gtk+-2.0 in the synaptic package manager, and found a list of matches, but I can't tell which, if any of them would solve my problem.
[Image: Synaptic.png]
 Any assistance would be appreciated.
It's been a while since I built nightingale but I think the package your looking for is libgtk2.0-dev.
(04-18-2016, 05:37 PM)Ezekiel000 Wrote: [ -> ]It's been a while since I built nightingale but I think the package your looking for is libgtk2.0-dev.

Yes, that was it, thanks. I finally got a successful build, and I was able to run the executable that was produced. Unfortunately, it shows the same lack of cover art as the binary distribution. I guess this is a problem I'll just have to put up with. Thanks for the help.
Well the work around would be to put a jpg copy of the cover art in the same folder, but that would only work if you store each album in a separate folder (which I think is normal but I don't want to assume).
You can find what to name it in Preferences->Artwork.
Thanks for the suggestion. My albums are in separate directories, so I could do this, but unless I could automate it, it would be quite labour intensive. I'll give it some thought.
Pages: 1 2